[bug] 2025-12-16 - 2025-12-18 8:25 AM PST 5:10 PM PST - Password Reset Not Working
Incident Overview
Date & Time (PST): 2025-12-16 5:10 PM - 2025-12-18 8:25 AM PST
Duration: 39 Hours
Severity: Low
Services Impact:
Password Reset
Customer Impact:
Cloud users of OEM Partners (nn-Nx) were unable to reset passwords
Root Cause
When a user requested a password reset, their account information was sent improperly to the OAuth2 service, causing a token to be generated only for Nx OEM. An OEM field was not populated by Cloud DB.
How We Fixed It
We added the missing field in the code, released a new version containing the fix, and then validated the password reset by testing it on the non-Nx Cloud hosts.
Corrective Actions
To avoid such issues in the future, we will include this scenario to automated tests.